Skip to main content

Web site Partly Compliant



  • Hi Gianluca,

    I think that the problem you have described above is caused by the fact that you are trying to implement Cookiebot twice. You are using both the cookiebot script and Google Tag Manager (GTM) to implement Cookiebot on your site.
    You should use only one method to enable Cookiebot on your domain, either by using the script directly or by using GTM.

    If you would like to use GTM for the implementation of Cookiebot then please check this link out:
    and follow the deployment procedure. 
    It is not necessary to add your own manually written code/script because and insert it on every page. 


  • Gianluca Corsini

    thanks for your answer.

    I had this problem even when the only script (in all the pages of my site) was just this:
    <script id = "Cookiebot" src = "" data-cbid = "0999820b-57ea-xxxx-xxxxxxxxxxxxxxxxxxxxe" type = "text / javascript" async> </script>
    <meta charset = "utf-8">

    But can you better explain to me what to set?

    Currently on my homepage I no longer have the cookiebot code but only this one from Google analytics:

    <script type = "text / plain" data-cookieconsent = "preferences, statistics, marketing" async src = ""> </ script >
      window.dataLayer = window.dataLayer || [];
      function gtag () {dataLayer.push (arguments);}
      gtag ('js', new Date ());
      gtag ('config', 'UA-xxxxxxxxx-1');
    </ Script>

    It's a mistake? How should I fix it ??

    But you are right about one thing: at the moment in the other pages of my site I have not yet done updates and there is also the code I wrote directly.

    I can also update all the pages immediately, but I had already tried this some days ago and it didn't work.
    And as I said, even when I had the simple code I wrote to you at the beginning of this answer I always had the same problem.

    Thanks for your help

  • Gianluca Corsini

    Hi, Now i have Google Tag Manager in all pages of my site:

    < head>
    <!-- Google Tag Manager -->
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    <!-- End Google Tag Manager -->

    <script type="text/plain" data-cookieconsent="preferences,statistics,marketing" async src=""></script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-xxxxxxxxxx-1');

    < /head>


    < body>

    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src=""
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
    < /body>

    and i have the same problem

    Can you help me?

  • Hi Gianluca,

    You should implement Cookiebot only once on your website. Either using the script and adding it to the head tag of your website ( or using Google Tag Manager (

    Also now you could you the new Cookiebot auto-blocking feature, which will help you a lot for the implementation of prior consent. You could check this article for more detailed information about GTM and Auto blocking mode



Please sign in to leave a comment.