Logo and checkboxes not shown

Comments

7 comments

  • Avatar
    Nadine Otten

    The domain is https://www.dukers-baelemans.nl/

    0
    Comment actions Permalink
  • Hi Nadine,

    After checking your domain it seems that you are using custom template for your Cookiebot banner/dialog, correct me if I am wrong. I can see that the logo is displayed in the left part of the dialog and I guess that you have not added the checkboxes and that is why they are not displayed.
    When using custom template you need to add the elements you want by yourself using the HTML placeholders and name conventions provided by Cookiebot. 
    If this is not the case, could you tell me how you have set the cookie dialog so I can take a look, you can post it here or send it at s.velinov@vconnect.dk

    Regards,
    Spas

    0
    Comment actions Permalink
  • Avatar
    Nadine Otten

    Hi Spas,

    I unpublished the new version in Tag Manager because the banner wasn't displayed properly. The banner you see is our old cookiebanner.

    I have made a print screen of the cookiebot banner which shows the problem:

    Regards,

    Nadine

    0
    Comment actions Permalink
  • Hi Nadine,

    Obviously, there is a misunderstanding because when I access this domain https://www.dukers-baelemans.nl/ the banner which pop-ups looks like this: 

    That is why I assumed that you are using custom template for your dialog. Do you confirm that this is the domain in question because it is strange that we are looking at the same domain and receive different output.

    Regards,
    Spas

    0
    Comment actions Permalink
  • Avatar
    Nadine Otten

    Hi Spas,

     

    That's because I removed it because it wasn't working. I've published it again so if you check that domain now again you will see what I mean. We are talking about the same domain.

     

    Regards, Nadine

     

    0
    Comment actions Permalink
  • Avatar
    Spas – vConnect – Community Supporter

    Hi Nadine,

    Now I see the above described problem. It seems that you have enabled Content Security Policy (CSP) on your domain. When inspecting the domain. following error message is displayed in the console:
    Refused to load the image '<URL>' because it violates the following Content Security Policy directive: "default-src https: 'unsafe-inline' 'unsafe-eval'". Note that 'img-src' was not explicitly set, so 'default-src' is used as a fallback.

    That is why the images (logo and checkboxes) are not displayed on the Cookiebot banner/dialog. You could solve this issue either enabling CSP in the server side, that means adding a Content-Security-Policy HTTP header or use <meta http-equiv="Content-Security-Policy" content="default-src 'self'; img-src https://*; child-src 'none';"> meta tags in the HTML

    Unfortunately, I could not provide you the exact meta tag which you need to add because this is something that you need to figure out by yourself depending on you domain. But there are really huge amount of information about this in the Internet so I believe that it won't be a problem for you to find out. 

    Regards, 
    Spas 

    0
    Comment actions Permalink
  • Avatar
    Nadine Otten

    Hi Spas,

    Thanks for your help. I will send this to our webdeveloper.

    Kind regards, 

     

    Nadine

    0
    Comment actions Permalink

Please sign in to leave a comment.