Internal links became broken after necessary cookies are allowed.

Comments

3 comments

  • Hi Denys,

    I think that the problem comes from the script you are using for routerLink. I guess that the script is automatically loaded/initiated on page load and therefore its working when reload the page and you first visit the website, then after accepting only necessary cookies the script (function) has been blocked. 
    I can see that you are using 'routerlinkactive' and add class="_active" on some links when you click them first and on that base these link are still working after you accept "necessary cookies only", because the links are already active. 

    However, please try to see which script is responsible for the router links and check whether this script is setting any cookies on the site. In case that the script is setting cookies on the site, you could assign these cookies as 'necessary' if its appropriate or add data-cookieconsent="ignore" to the script-tag. 

    Regards,
    Spas

     

    0
    Comment actions Permalink
  • Avatar
    Denys Dzhel

    Hi Spas, thanks for quick response.

    If user not allow some cookies and you blocked them once why they working after page reload ?

    data-cookieconsent="ignore" does nothing on bundle which deal with cookies.

    Regards,
    Denys

    0
    Comment actions Permalink
  • Avatar
    Denys Dzhel

    Hi Spas,

    maybe you have any other solutions? except set blocking mode to manual.

    0
    Comment actions Permalink

Please sign in to leave a comment.