Skip to main content

The Auto Block, blocks my pictures on my website

Comments

9 comments

  • Spas – vConnect – Community Supporter

    Hi Robin, 

    This is expected behavior of Cookiebot auto blocking mode. What you are describing is because automatic cookie blocking feature holds back any script that sets other than strictly necessary cookies until user consent for the specific cookie category has been obtained.

    The reason why the auto blocking mode does not display images is that those elements are setting cookies on the site and therefore they have been hold on (not displayed) until the consent is given. When consent is given and cookies have been allowed those elements are displayed on the website.
    This is how auto blocking mode works, it hold/blocks all elements which are setting cookies on the website until those cookies have been allowed.
    For more detailed information please check this article: https://support.cookiebot.com/hc/en-us/articles/360009063100-Automatic-Cookie-Blocking-How-does-it-work-

    However, I suggest you to investigate why images on your website are classified ad a marketing cookies (if they are coming from somewhere or if they have any special attributes and etc). You could also check which marketing cookies are set with the images on the website and then classify them as necessary (if this is appropriate). 

    Regards,
    Spas

    0
  • a

    How can i check wich marketing cookies are set with the images on the website and classify them as necessary?

    0
  • Spas – vConnect – Community Supporter

    Hi Robin, 

    The easiest way you could check which marketing cookies are set within the images on the website by using the inspector console of your browser. Just do a right click on the website and then inspect it, after that go to application tab and check cookies (chrome). Investigate which cookies are set after accepting 'marketing' cookie category and try to see from where those cookies are being set. 

    Regards,
    Spas

    0
  • a

    i figured out that the auto block, blocks nessesary cookies. This cookies are: _pay_session, shopify_pay_redirect. This cookies are categorized as nessesary but the auto block skript blocks them. So pls can you fix that? 

    0
  • Spas – vConnect – Community Supporter

    Hi Robin, 

    In case that those necessary cookies are being set by a script tag that also sets other categories of cookies, e.g. marketing-cookies. The tag will then only be activated if the user consents to marketing cookies.
    The other possible reason is that Cookiebot not actively blocks those cookies because of the script which is setting them. I think there's errors that cause the scripts to not be able to run properly and fail to set the cookies. This could be cause because Cookiebot script is not first to load on the website.
    You could try to add the data-cookieconsent="ignore" attribute to the script that sets those cookies.

    Regards,
    Spas

    0
  • a

    The problem is, that i havent an access to the cookies, cause my host is shopify...

    0
  • Spas – vConnect – Community Supporter

    Hi Robin, 

    In case that you do not have access to specific script which sets cookies though the Shopify admin panel then you should modify those scripts from the source code of your website. 
    To enable prior consent (block cookies until the user has consented), you could manually apply the attribute "data-cookieconsent" to all script tags setting cookies. Set the comma-separated value of the attribute to one or more of the three types of cookies: "preferences", "statistics" and "marketing" in accordance with the types of cookies being set by each script. Finally change the script tag attribute "type" from "text/javascript" to "text/plain". 
    For example, make the following change to the code:

    $javascript .= "<script type=\"text/javascript\">
    becomes:
    $javascript .= "<script type=\"text/plain\" data-cookieconsent=\"statistics"\>

    You could also add the data-cookieconsent="ignore" attribute to the script that sets cookies.

    Regards,
    Spas

    0
  • shie alse

    I'm no professional, I simply selected "manual" and my issues had been gone. I'll try to set it lower back to "automatic" once more quickly due to the fact to get helpas I apprehend it's miles the quality manner. I'm now not with Cookiebot, I'm just a consumer such as you :)

    0
  • Anja

    Hi! I am having the same issue - we have narrowed the issue down to Statistics cookies, then moved all cookies to REquired, to troubleshoot, so now the Statistics section is empty. However, toggling it on still fixes the problem and toggling it off stops all images from showing. We are on Shopify, Prestige theme.

    siccaro.dk

    0

Please sign in to leave a comment.