img tag and cookiebot

Comments

4 comments

  • Avatar
    Kevin Choppin

    I also have this issue, CookieBot is preventing my lazy loading script from executing properly and images on my site are not displaying at all.

    Removing the CookieBot script entirely fixes the issue. Moving the CookieBot script until after the lazy loading script has loaded also fixes the issue, but doing this allows cookies to be placed before CookieBot can intercept.

    Also, if the CookieBot script is in the head and a user accepts all cookies, lazy loaded images will display correctly after a refresh. But if a user only accepts some cookies the issue remains.

    Is there any fix for this issue?

    0
    Comment actions Permalink
  • Hi Helmut and Kevin,

    Regarding the issue that 'data-src' get's converted to a 'src' and then part of your images appear to be broken I can say that Cookiebot have recently changed from using data-src as internal attribute, so this issue should have been resolved by now.
    Please re-scan your domain and check if the issue is still present. 

    Regarding the issue that CookieBot is preventing the lazy loading script from executing properly, this is caused by a lazy loading framework setting cookies. So basically the framework will not work when the user has not consented to these cookies. Please check the cookies which are being set from the lazy loading script and classify them if possible. 

    Regards,
    Spas



    0
    Comment actions Permalink
  • Avatar
    Kevin Choppin

    Thanks for your response Spas

    My lazyloading script is not a framework, it is vanilla JS and no cookies are being set.

    I will try rescanning the domain.

    0
    Comment actions Permalink
  • Hi Kevin,

    Please do the re-scan. Also please do not hesitate to write us back in case of any problem.

    Regards,
    Spas

    0
    Comment actions Permalink

Please sign in to leave a comment.