Skip to main content

WPEngine CDN issue

Comments

13 comments

  • Hi Bishoy A,

    What you are describing is not a issue, but usual Cookiebot behavior, because this is how Cookiebot works. Cookiebot blocks/holds all resources (script, links, plugins) which are setting cookies on the website until the user allows them. 
    You could find more information about this here: https://support.cookiebot.com/hc/en-us/articles/360004104033-What-does-prior-consent-mean-and-how-do-I-implement-it-

    About the Chrome issue with Cookiebot, I think that this is caused by the browser itself. Could you please check the 'viewport' settings of your website and Chrome 'initial-scale'.

    Regards,
    Spas

    0
  • Lennart Schreiber

    This IS an issue, because our own CDN Url should not be hidden if no (or only essential) cookies are accepted.

    We need a function to whitelist our CDN url, or cookiebot (in auto mode) is not possible to use.

    f.e. our url: domain.com and our cdn: cdn.domain.com - it's only a subdomain from our main domain!

    1
  • Hi Lennart,

    You could add data-cookieconsent="ignore" attribute to your CDN Url script in order to load it even without accepting cookies. Usually Cookiebot blocks all scripts which set cookies on the website before giving appropriate consent, this is regarding the eu GDPR rules. Cookiebot holds/block all resources which set cookies, it doesn't matter if its your own or a third-party. 

    Regards,
    Spas

    0
  • Lennart Schreiber

    It's not a CDN URL Skript - it's all the images on our website. They all have a CDN URL as src - and are not loaded anymore with AUTO Mode from cookiebot. This has nothing to do with EU GDPR Rules - because it's our own CDN (subdomain!) and no cookies are used or any data is shared with a third party.

    CookieBot (or the wordpress plugin for cookiebot) should allow everything from subdomains or should offer a whitelist of urls - which are never blocked in any way.

    1
  • niklas.karkinen

    I also agree that this is an issue. We cannot present a broken homepage at first load just because we use a CDN. 

    0
  • Kiterocket Programmers

    agree with that. any solution/workaround?

    0
  • Thomas Kahn

    We see the same behaviour.
    All resources loaded from the CDN are blocked before uc.js has been loaded and has had the time to evaluate the user cookie settings. Here's a screenshot from the network traffic we see:

    Here's what happens:

    1. The HTML document is loaded.
    2. Resources that are hosted on the CDN tries to load but fail.
    3. The us.js javascript is loaded.

    After uc.js has loaded and executed, all the images load AGAIN and this time they are let through:

    These two screenshots are from the same load of a single page.

    We've been in contact with the CDN just to double-check that they don't write any cookies or do any form of tracking and they don't.

    My analysis of what is happening is that even though uc.js is the first script tag in the head of the document, the browser also starts loading images from the CDN in parallel. And since Cookiebot hasn't had a chance to evaluate these loads it blocks them.

    I have no solution for this - just documenting what we're seeing so that we might come up with a solution together.

    0
  • Frank Biemans

    Good afternoon guys.

    We are basically running into the same issue as Thomas describes above.

    Some images (wether is PBG, JPG or SVG) are blocked and some are not.

    Does anyone have any (possible) solutions? 

    0
  • Robinmax

    This IS an issue, because our own CDN Url should not be hidden if no (or only essential) cookies are accepted.

    We need a function to whitelist our CDN url, or cookiebot (in auto mode) is not possible to use.

    f.e. our url: domain.com and our cdn: cdn.domain.com - it's only a subdomain from our main domain!

    0
  • Harry Arthur

    Well. This discussion helps me a lot. Thanks Guys!

    0
  • Lea Braun

    I've got the same issue on multiple websites and this really annoys me. I cannot present a website without pictures unless all cookies are accepted.

    Does anybody have a fix for this? Is there any Community Supporter who wants to help here or is my only possible solution to move all of my websites to another consent management tool?

    0
  • Louise Wener

    Answer: WPEngine is great, but their CDN can sometimes be an issue. Here's how to fix it.

    If you're having issues with your WPEngine website loading slowly, it could be an issue with the content delivery network (CDN). While WPEngine is great, their CDN can sometimes be an issue, causing slow page load times.

    There are a few things you can do to try and fix this problem:

    1. Try clearing your browser's cache and cookies. This will often help speed up page load times, as it will remove any old or stale data that may be causing issues.

    2. Check your DNS settings. Make sure that your DNS server is set to the correct IP

    0
  • Per Flitig

    We're having the same issue described by Thomas Khan. Is there any solution to this? Unless user has consented to all cookies every image loaded from our CDN on the site fails to load until after the uc.js script has loaded, effectively causing them to flash. It's not acceptable behaviour.

    0

Please sign in to leave a comment.