Corrupted forms in IE, Edge

Comments

21 comments

  • Official comment
    Avatar
    Brian Mørkeberg Lundkvist

    Dear all, a fix for this was released earlier today and you should no longer see this unintended behavior. Sorry for any inconvenience this has caused.

    Comment actions Permalink
  • Avatar
    andrew hutchings

    I have also found the same problem, the same error when the forms method is changed from "POST" to "GET" . Only does this in IE 11 for me. 

     

    This is preventing all sales via ie as none of the forms on our client's website can be submitted. 

    0
    Comment actions Permalink
  • Avatar
    Kenan

    Hi Friederich and Andrew,

    Thanks for reaching out.

    We will release a bugfix tomorrow.

    Sorry for any inconvenience.

    0
    Comment actions Permalink
  • Avatar
    Jean-Manuel BARON

    I have the same problem here, it is very critical for our website... Please inform us as soon as the bugfix is released.

    0
    Comment actions Permalink
  • Avatar
    Tobias Bethäuser

    Hi everyone,

    i have the same problem and have been following this thread 1h after it was created.

    The form method was changed from post to get and also the position where the tag param is placed changed.

    After the fix it says post again but the position still changed, so cookiebot seems to do something with it.

    However, a look at the access.log of the webserver tells me that if i search via Internet Edge the form is still send via GET and in Chrome it is send via POST.

    If I deactivate cookiebot everything works fine. So the workaround seems to fix the problem in the html code, but the problem still exists because I dont get any form data in Internet Edge.

    0
    Comment actions Permalink
  • Avatar
    Kenan

    Hi Tobias,

    Could you provide us a website we can test on ?

    You can send it either here or at support@cookiebot.com - we can 'fake' cookiebot with autoblocking on the site for debugging purposes, so you don't have to enable it.

    0
    Comment actions Permalink
  • Avatar
    Friedrich Wolfram

    I can confirm, that the issue still exists. First the form is submissed via POST and the immediately follows a GET. The payload in POST request contains an empty line prior the entered data.

    You can test with our search form at `hypovbg.at/suche`. The term `test` should return around 493 results

    0
    Comment actions Permalink
  • Avatar
    Kenan

    Thanks, issue confirmed.

    We'll look into it and get back shortly.

    0
    Comment actions Permalink
  • Avatar
    Jean-Manuel BARON

    Do you have any news on this issue ?

    0
    Comment actions Permalink
  • Avatar
    Jean-Manuel BARON

    Still no news ?

    0
    Comment actions Permalink
  • Avatar
    Hendrik

    Do you have any news on this issue? We´re having problems implemeting it on our clients websites.
    If the issue can´t be fixed quickly we have to look for a other solution or provider.

    0
    Comment actions Permalink
  • Avatar
    Patrick

    Same Problem on all our Websites with Cookiebot if you use IE or Edge!

    If data-blocking mode = "auto", regular forms via POST will not work!
    Therefore users who use Edge or IE cannot use the website as long as data-blocking-mode = "auto" is used.
    We have now removed data-blocking-mode = "auto" in the include script so that at least the users can use the website!

    This error occurs with everyone! Therefore inevitable that this will be fixed immediately! Thank you

     

    0
    Comment actions Permalink
  • Avatar
    Kenan

    Current version of Edge does not fully support a certain standard that is used by the auto-blocking functionality in Cookiebot which leads to the error you experience where FORMs using POST-method in some cases will not work, when the POSTed content is used in the response on the next page which the user is navigating to after the POST.


    The problem will be solved in the next version of Edge, which according to Microsoft will be released in January 2020. If you don’t want to wait for that, these are the possible workarounds:

    • Change FORM method from POST to GET
    • POST the form data to an URL (“action” on the FORM-tag) that registers the submitted data and then immediately re-redirects the user to a different confirmation page.
    • Disable auto-blocking on the Cookiebot-tag and use manual blocking instead

    The above approach has also been tested in Explorer and works.

    0
    Comment actions Permalink
  • Avatar
    Hendrik

    Very sad to hear that.
    The workaround shureley will work für search requests but we´re unable to use this workaround for contact forms.
    Sorry … but we will switch to an other provider.

    0
    Comment actions Permalink
  • Avatar
    Kenan

    Sorry to hear that Hendrik,

    Cookiebot is the only CMP in the world that has autoblocking, and switching to another provider would mean that you would have to block cookies manually, just as you can with our manual blocking mode (step 4). Manual-blocking was the defacto standard until some months ago, where we released the autoblocking feature. Although it may have some shortcomings right now, they will eventually be fixed, and switching to another provider will not help you.

    Regards

     

    0
    Comment actions Permalink
  • Avatar
    Christian Walter

    Could you give an information if the release of Microsoft is done and the problem is solved now?
    Do you retest if it works now as expected?

    0
    Comment actions Permalink
  • Avatar
    Hendrik

    Sorry that we have to insist on this, but the problem is still present in IE11 11.0.175. It is not possible to submit forms with method="post".

    When do you expect to fix this?

    0
    Comment actions Permalink
  • Avatar
    Keld Jakobsen

    Were having same kind of problem but not only in Edge, but also Chrome. Our CMS uses virtual urls and when implementing Cookiebot its changes the url of the form action to an internal path which destrois posting forms

    0
    Comment actions Permalink
  • Hi, 

    This issue has been reported and a fix was released a few months ago and it had been fixed. 
    As Kenan mentioned in the previous comments this is actually not a Cookiebot bug but it is a limitation on browser level. The old versions of Edge and all versions of Internet Explorer do not fully support a certain standard that is used by the auto-blocking functionality in Cookiebot which leads to the error you experience where FORMs using POST-method in some cases will not work, when the POSTed content is used in the response on the next page which the user is navigating to after the POST.
    The problem was solved in the new version of Edge, which was released in January 2020.Possible workarounds for Internet Explorer and "old" Edge browsers:

    Change FORM method from POST to GET

    POST the form data to an URL (“action” on the FORM-tag) that registers the submitted data and then immediately re-redirects the user to a different confirmation page.

    Disable auto-blocking on the Cookiebot-tag

    This is only a problem in old version of Edge and Internet Explorer and not in other browsers. 
    Basically, Internet Explorer and partly Old Edge don't support the JavaScript MutationObserver object which is used by auto-blocker. As a fallback-mechanism we use the XMLHttpRequest object to re-post forms, but as we can't read out POST values client side in IE/old Edge, it does not work, unless implemented as suggested in the workarounds.

    Regards,
    Spas

     

    0
    Comment actions Permalink
  • Avatar
    Gerald Jelitto

    If MutationObserver is the problem:

    Would it be a solution to use a polyfill like this one here?

    https://www.npmjs.com/package/mutationobserver-polyfill

     

    0
    Comment actions Permalink
  • Avatar
    Kenan

    Thanks for the suggestion Gerald, we will investigate it ASAP.

    0
    Comment actions Permalink

Please sign in to leave a comment.