Skip to main content

Google Recaptcha field only loads if marketing cookies are enabled.



  • Hi Thomas,

    Your google recaptcha fields have been hided before giving consent because they set cookies on the site and therefore they are blocked until the user allows them. This is how Cookiebot works, it blocks/holds all cookies until the user allows them. 
    In your case the google recaptcha is considered to set marketing cookies on the site and that is why the recatpcha fields are being hided before giving a consent regarding marketing cookies. 
    You could find more information about prior consent here:


  • Thomas Muscroft

    Hi Spas,

    I understand that cookiebot blocks cookies until they have been accepted, but we as admins should be able to make specific cookies necessary.

    I have tried manually setting all our marketing cookies (picked up by cookiebot scan) to necessary and even when i do this and marketing cookies is empty, you still have to allow marketing cookies for the recaptcha to show.

    There has to be a way for google recaptcha to show, with only necessary cookies accepted.


  • Hi Thomas,

    After assigning cookies to specific categories, the changes won't take effect until after a new scan has been completed. Since the configuration.js file still tells the auto-blocking feature the scripts are classified as marketing. That is why the cookies are still considered as marketing and you would need to allow marketing cookies in order to load them on the site.
    The file will be updated after a scan. But you could also activate a manual scan from the manager if you do not want to wait.


  • NP CookieBot

    We are facing exactly the same problem using ReCaptcha v2: No ReCaptcha until Marketing cookies are accepted, even after rescanning and verifying the ReCaptcha cookies are in the "Necessary" category and the "Marketing" category is empty.

    How can we verify that configuration.js has been updated after a manual scan?

    Any news on this? 

  • Hi NP CookieBot,

    You could not really verify that configuration.js has been updated after a manual scan, because they would have to know the content before and after the scan, since the file is generated based on the scanner's finding though.
    However, the Recaptcha is being blocked because it set cookies on the site, you can force ReCaptcha to load by assigning the script tag this attribute: data-cookieconsent="ignore", but please have in mind that this will result in cookies being set without consent.


  • Thomas Muscroft

    Hi All,

    After more than a week of back and forth with cookiebot support team, it looks like there is no solution to this issue.

    Here is what support have said to me:

    "I just spoke to our developers. They explained that the NID cookie from Google is a marketing tracker (look under "Advertising" here:"). Because of this Cookiebot will never accept it as necessary. 

    The reason changing category in the manager doesn't change the behavior of the automatic blocking script, is that is on the "fallback"-list of domains which are always considered to be marketing-trackers, no matter what the customer categorizes cookies from as."

    I asked that ther must be a solution and got this:

    "Technically, the data-cookieconsent="ignore" attribute would still work. I tried seeing if I could get ReCaptcha to work doing this, but I was unsuccessful. There seem to be several scripts that have something to do with ReCaptcha, but the closest I got to get it to work was that the space and a border got displayed, but not the actual widget.

    You can try to see if you can get it to work, but I'm not sure it's even desirable to make ReCaptcha work at all costs. Doing so would mean you're not GDPR compliant, because using ReCaptcha isn't strictly necessary for your page to work. Removing the script will make your contact form work."

    My only solution now is to have an if statement to block the cookiebot script from running on my contact page, although this will mean we are not fully GDPR Compliant. Not sure what else to do, as we need recaptcha to prevent a large amount of spam being recieved.

  • Yannis


    I have the same problem, google reCaptcha does not working even if I add NID in neseccary cookies.

    Do you plan to fix this?

  • Brian Mørkeberg Lundkvist

    Hi all

    Google collects personal data through ReCaptcha. 
    To be compliant with ePR, GDPR, etc. the user must have opted in to marketing cookies before ReCaptcha can be used.
    As user consent to marketing cookies is required for ReCaptcha to load and function correctly, we recommend using our css functionality to hide the submit button of your form and instead show a place holder and a message to accept cookies.

    Here is an example of a div, shown if there has not been an optin to marketing.
    <div class="cookieconsent-optout-marketing">
      Please <a href="javascript:Cookiebot.renew()">accept marketing-cookies</a> to enable this form.

    Adding the class "cookieconsent-optout-marketing" to your form's submit button would hide it until the user has accepted marketing cookies.

    You may want to consider showing a disabled submit button with the text above for better UX.

  • Soporte SORT

    HI, I have the same problem witch recaptcha v3.

    Google reCaptcha does not working even if I add NID in necessary cookies. If marketing cookies not accepted, the form doesn't work 

    Do you plan to fix this? please, is urgent!

  • ashjs ase

    If you think this is necessary, the workaround here will be to add eventListeners to the buttons that execute location.reload() method that reloads the current link, like the Refresh button.


Please sign in to leave a comment.