Cookiebot script does not work with other scripts in Wordpress

Comments

8 comments

  • Hi Pau,

    You should add the Cookiebot script at the very top within the HEAD-tag of your website, not in the header. Please check the general implementation guide for more detailed information because this may be one of the reason why Cookiebot conflicts with other scripts and plugins: https://www.cookiebot.com/en/help/

    However, the other reason why Cookiebot might blocks other scripts and plugins is that those scripts/plugins are setting cookies which are not classified and allowed by the visitors and therefore Cookiebot does not load them. If other scripts/plugins are setting cookies on the website you should classify those cookies and enable prior consent. 
    Another solution which might works is to move/include the other scripts to the footer so they do not conflict with Cookiebot script which should be added into the head tag of your website.

    Regards,
    Spas

    0
    Comment actions Permalink
  • Avatar
    Pau Sanz

    Hello,

    I have been trying the different proposals or solutions that you have written to me, but they are not satisfactory when it comes to solving my problem with the Cookiebot script with the other plugins or scripts of my wordpress.

    It still doesn't work if I apply the Cookiebot script inside the head tag and everything else stops working. Can I attach any capture or image? or access to the wordpess website where the problem occurs.

    Thank you.

    0
    Comment actions Permalink
  • Hi Pau,

    Could you please tell we if the other scripts/plugins work after giving a consent and allowing all cookies on the site.
    I am asking this because in case that other scripts/plugins are working after allowing cookies this means that everything is working as it should. This is how Cookiebot works, it blocks/holds all elements which are setting cookies on the site until the user allow them. 
    This is not a bug or a problem, this is how Cookiebot works and expected behavior regarding the GDPR requirements.  


    Regards,
    Spas

    0
    Comment actions Permalink
  • Avatar
    Pau Sanz

    Hello again,

    I have checked and looked at what you have said that by accepting cookies you can see the website 100% correctly with the other plugins, galleries, videos, etc. But unfortunately, Cookiebot compatibility on my website still doesn't work.

    The other scripts on my website still fail if I have activated your Cookiebot.

    Thank you

    0
    Comment actions Permalink
  • Avatar
    Pau Sanz

    and im using this wordpress theme: Graphene Plus 2.6.3v and Graphene 2.7v

    and i have these pluguins actived:

    - Smush
    - TinyMCE Advanced
    - Tawk.to Live Chat
    - WP All Export
    - WP Super Cache
    - WP Responsive Recent Post Slider/Carousel
    - WP-Optimize - Clean, Compress, Cache
    - WPML Multilingual CMS
    - Yoast SEO
    - Slider Revolution
    - Shortcodes Ultimate
    - Popup Builder
    - MC4WP: Mailchimp for WordPress
    - iThemes Security
    - Hummingbird
    - Gravity Forms
    - Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream
    - Editor clásico
    - CSS Plus
    - Autoptimize
    - Async JavaScript
    - Akismet Anti-Spam

     

    Thank you.

    0
    Comment actions Permalink
  • Hi Pau,

    If the website is working properly after accepting cookies then the problem does not comes from Cookiebot. 
    The other plugins and script are not working because they have been blocked (hold on) until user gives consent. This is not a problem, it is actually an expected behavior and how Cookiebot works. 

    Regarding the GDPR requirements all scripts and plugins which load cookies on the site needs to be hold on/block until the user gives consent and allow them. All script and plugins which are setting cookies need to be blocked until the user allows them. In case that your plugins are not working before consent is given and afterwards everything is working correctly when cookies are allowed, this means that Cookiebot is working as it should and you have enabled prior consent.  

    Regards,
    Spas

    0
    Comment actions Permalink
  • Avatar
    Pau Sanz

    Hello again,

    the problem still appears even if the user gives consent and accepts cookies and does not appear at any time photos, videos, galleries, etc.

    Thank you.

    0
    Comment actions Permalink
  • Hi Pau,

    Could you please provide us with more details about the issue (URL of your domain,description of the problem, steps to reproduce, some images/videos), any information would be useful and appreciated. Obviously we would need to have a closer look so we could help you solve the issue instead of guessing. Please write to support@cookiebot.com with description of the problem. 

    Regards,
    Spas

    0
    Comment actions Permalink

Please sign in to leave a comment.