Cookiebot breaks some Wordpress plugins

Comments

6 comments

  • Official comment
    Avatar
    Richard van der Velde

    Hi Dirk,

    I've just checked the page on Chrome and Edge. On Chrome, the calendar looks as I'd expect. In Edge however, I get the same result as you do. Just two headers, nothing more.
    The console in Edge also shows a great deal of errors, which likely causes the execution of scripts to stop, resulting in a broken plugin.

    I'll have the guys in our development team have closer look.

    Comment actions Permalink
  • Hi Tolerant,

    In case that the problem does not occur when cookie blocking mode is set to Manual, I assume that the reason this happens is probably that a script that another script is dependent on is blocked (on automatic cookie blocking mode). This causes an error, and stops JavaScripts from executing and therefore makes conflicts between different plugins.

    However, there has been a major update released last weekend that should solve these issues. Could you please confirm if you are still experiencing the above described issue so we could investigate further more.
    If the issue is not resolved please provide us with more detailed information (domain name, steps to reproduce, etc) so we could help you solve the issue instead of guessing. 

    Regards,
    Spas

    0
    Comment actions Permalink
  • Avatar
    Tolerant Webmaster

    Hi Spas,

    Thanks for your reply.

    I did not seen an update for the Cookiebot plugin, which is still on version 3.1.0.

    I tested again but the situation is still the same.

    I have the issue on my production site, but I created a test page with only a Pinpoint Booking calendar on it (without making use of Elementor. 

    https://tolerant-vzw.be/booking/

    WIth manual blocking mode, (which is set now), a calendar should appear.

    As soon as automatic blocking mode is set, only the page header (the word "Booking" at the top) is displayed.

    I'm not familiar with Wordpress internals and scripting, so I did not perform any customization to the site.

    The site is using the 'Customizr Pro' theme from Press Customizr.

    What I did notice on the coockiebot report is that the cookies set by Pinpoint Booking System are mentioned as 'unclassified'. Maybe that is part of the problem.  (see below)

    The calendar is not in production yet, so I can always change the blocking mode for a while if needed to test.

    Best regards,
    Dirk

    COOKIE NAME PROVIDER TYPE EXPIRY
    pinpoint_ounicutevdxxtvpl tolerant-vzw.be HTTP Session
    First found URL: https://tolerant-vzw.be/
    Cookie purpose description: Unclassified
    Initiator: Webserver
    Source: tolerant-vzw.be
    Data is sent to: Belgium (adequate)
    Prior consent enabled: No

     

    0
    Comment actions Permalink
  • Avatar
    Tolerant Webmaster

    Hi,

    I just tested version 3.2.0 of the plugin. Elementor is now working normally and also Pinpoint Booking Calendar is now loading on the page link that I have given above. Great!

    However, in production, I have a more nested setup. The Pinpoint Booking Calendar is actually configured inside an EventOn event page. The EventOn shortcodes are configured on Elementor tab pages using an 'Always Elementor' encapsulation due to some issues with EventOn and Elementor. 

    Anyhow, this is the page link where two tabs should open, but in my case with blocking mode Auto, it stops at displaying the tab headers (Evenementenkalender Vaarkalender). 

    https://tolerant-vzw.be/kalender/

    So I guess there will probably also be some conflict with the EventOn plugin.

    Brgds,

    Dirk

     

    0
    Comment actions Permalink
  • Avatar
    Tolerant Webmaster

    What you can test on following page:

    https://tolerant-vzw.be/kalender/

    On the second tab (Vaarkalender), click on 'Test Vaartocht'. This opens an event and at the bottom; a Pinpoint Booking Calendar form appears.

    This works fine with Chrome and Edge with blocking mode on manual (which is the current setting).

    I can always change the setting to automatic for a while to allow for testing.

    Thanks

    Dirk

     

    0
    Comment actions Permalink
  • Avatar
    Tolerant Webmaster

    Good morning,

    The latest update 3.3.0 seems to fix the problem. I'm running on automatic now and will further monitor.

    Thanks!!

    Dirk

    0
    Comment actions Permalink

Please sign in to leave a comment.